YABOG: Toutes les unités

Toutes les unités

Nom | Description
IHM | Interface Homme Machine
LAN | Interface réseau de YABOG
moteur | Le moteur de YABOG
Param |
Skin | Gestion des skins de YABOG
Traduc |
Utils |
_Bib | Gestion de la bibliothèque d'ouvertures
_Biblio |
_systeme |


YABOG: IHM

Unité IHM

Description

Interface Homme Machine

Pas de véritable commentaires pour ce source sinon pour dire qu'il est rempli de bugs. A FAIRE : - mettre le code au propre - rendre le code plus robuste - utiliser "showmessage" - mettre info "qui joue" - faire une fenêtre "about" - ...

Classes, interfaces and objects

Nom | Description
Classe TFormPrincipal |

Types

Nom | Description
TLesJoueurs |

Constantes

Nom | Description
CaseX | valeur des cases se référant à Label1 et autres

Variables

Nom | Description
FormPrincipal |

Auteur

Eric Sallou <esallou@free.fr>

Dernière modification

1er Janvier 2004


YABOG: IHM: Classe TFormPrincipal

Classe TFormPrincipal

Unité

IHM

Déclaration

type TFormPrincipal = class(TForm)

Description

Champs

 | Nom | Description
Public | AuTourDuJoueur |
Public | ConnectButton |
Public | DisconnectButton |
Public | ImgBckg |
Public | JouerEnReseau |
Public | LAN | Déclarations de l'objet LAN
Public | LesJoueurs |
Public | ProfilYabo |
Public | SendButton |
Public | TempLANPort |
Public | YaboTournoi |

Méthodes

Aperçu

Public | Procedure AfficheParametrage(Sender: TObject);
Public | Procedure AffichePionJoue(valeur: Byte; Blanc: Boolean);
Public | Procedure AjouteDisplayMemo(Msg: String);
Public | Procedure Arret(Sender: TObject);
Public | Procedure ConnectButtonClick(Sender: TObject);
Public | Procedure DebutDePartie;
Public | Procedure DisconnectButtonClick(Sender: TObject);
Public | Procedure EnableMessageEdit(Flag: Boolean);
Public | Procedure FinDePartie;
Public | Procedure FormCreate(Sender: TObject);
Public | Procedure FormDestroy(Sender: TObject);
Public | Procedure FormMouseDown(Sender: TObject; Button: TMouseButton;Shift: TShiftState; X, Y: Integer);
Public | Procedure FormMouseMove(Sender: TObject; Shift: TShiftState; X,Y: Integer);
Public | Procedure FormMouseUp(Sender: TObject; Button: TMouseButton;Shift: TShiftState; X, Y: Integer);
Public | Procedure ImageDamierMouseDown(Sender: TObject; Button: TMouseButton;Shift: TShiftState; X, Y: Integer);
Public | Procedure JoueSon(NomSon : String);
Public | Procedure LancerJeu(Sender: TObject);
Public | Procedure MetCurseur(num: Byte; Nom: String);
Public | Procedure SendButtonClick(Sender: TObject);
Public | Procedure TraiteCommande(Ligne: String);
Public | Procedure TraiteJeu(valeur: Byte; Advers: Boolean);
Public | Procedure TraitePolice(installation: Boolean; Nom: String);

Description

Public Procedure AfficheParametrage(Sender: TObject);

Fenetre param & aide

Public Procedure AffichePionJoue(valeur: Byte; Blanc: Boolean);

Affiche dans le Memo le coup du Joueur

Public Procedure AjouteDisplayMemo(Msg: String);

Public Procedure Arret(Sender: TObject);

Public Procedure ConnectButtonClick(Sender: TObject);

Public Procedure DebutDePartie;

Public Procedure DisconnectButtonClick(Sender: TObject);

Public Procedure EnableMessageEdit(Flag: Boolean);

Public Procedure FinDePartie;

Public Procedure FormCreate(Sender: TObject);

Public Procedure FormDestroy(Sender: TObject);

Public Procedure FormMouseDown(Sender: TObject; Button: TMouseButton;Shift: TShiftState; X, Y: Integer);

Public Procedure FormMouseMove(Sender: TObject; Shift: TShiftState; X,Y: Integer);

Public Procedure FormMouseUp(Sender: TObject; Button: TMouseButton;Shift: TShiftState; X, Y: Integer);

Public Procedure ImageDamierMouseDown(Sender: TObject; Button: TMouseButton;Shift: TShiftState; X, Y: Integer);

Public Procedure JoueSon(NomSon : String);

Public Procedure LancerJeu(Sender: TObject);

Public Procedure MetCurseur(num: Byte; Nom: String);

Met un curseur (format CUR ou ANI)

Public Procedure SendButtonClick(Sender: TObject);

Public Procedure TraiteCommande(Ligne: String);

Public Procedure TraiteJeu(valeur: Byte; Advers: Boolean);

Public Procedure TraitePolice(installation: Boolean; Nom: String);

installe ou désinstalle des polices (format TTF)

Propriétés

Aperçu

Public property AllowDrag: Boolean;

Description

Public property AllowDrag: Boolean;


YABOG: LAN

Unité LAN

Description

Interface réseau de YABOG

Pas de véritable commentaires pour ce source. A FAIRE : - mettre le code au propre - rendre le code plus robuste - vérifier le fonctionnement - faire un lien vers la langue - gérer les proxies - gérer des protocoles type GGF - intégrer un annuaire

Classes, interfaces and objects

Nom | Description
Classe TLAN |

Auteur

Eric Sallou <esallou@free.fr>

Dernière modification

1er Janvier 2004


YABOG: LAN: Classe TLAN

Classe TLAN

Unité

LAN

Déclaration

type TLAN = class

Description

Champs

 | Nom | Description
Public | CliWSocket |
Public | LANPort |
Public | RcvBuf |
Public | RcvLen |
Public | SrvWSocket |
Public | TmpWSocket |

Méthodes

Aperçu

Public | Constructor Create;
Public | Destructor Free;
Public | Procedure CliWSocketDataAvailable(Sender: TObject; Error: Word);
Public | Procedure CliWSocketDnsLookupDone(Sender: TObject; Error: Word);
Public | Procedure CliWSocketSessionClosed(Sender: TObject; Error: Word);
Public | Procedure CliWSocketSessionConnected(Sender: TObject; Error: Word);
Public | Procedure EnvoiMsg(Msg: String);
Public | Procedure SrvWSocketSessionAvailable(Sender: TObject; Error: Word);
Public | Procedure StartServer;

Description

Public Constructor Create;

Public Destructor Free;

Public Procedure CliWSocketDataAvailable(Sender: TObject; Error: Word);

Public Procedure CliWSocketDnsLookupDone(Sender: TObject; Error: Word);

Public Procedure CliWSocketSessionClosed(Sender: TObject; Error: Word);

Public Procedure CliWSocketSessionConnected(Sender: TObject; Error: Word);

Public Procedure EnvoiMsg(Msg: String);

Public Procedure SrvWSocketSessionAvailable(Sender: TObject; Error: Word);

Public Procedure StartServer;


YABOG: moteur

Unité moteur

Description

Le moteur de YABOG

Pas de véritable commentaires pour ce source. A FAIRE : - mettre le code au propre - rendre le code plus robuste - intégrer la gestion de bibliothèque - gérer les profils - vérifier la destruction de branches (libération mémoire) - intégrer fonctions externes

Classes, interfaces and objects

Nom | Description
Classe TSitu |
Classe TYABOG |

Types

Nom | Description
TCouleur |
TLigne |

Constantes

Nom | Description
CaseX | Tester List.Capacity := Count avant chaque ADD
Triangle |

Variables

Nom | Description
YABOG |

Auteur

Eric Sallou <esallou@free.fr>

Dernière modification

1er Janvier 2004


YABOG: moteur: Classe TSitu

Classe TSitu

Unité

moteur

Déclaration

type TSitu = class

Description

Champs

 | Nom | Description
Public | DerniereCase |
Public | Grille |
Public | Suites |
Public | Valeur |

Méthodes

Aperçu

Public | Constructor Create;
Public | Destructor Destroy; Override;
Public | Function AlphaBeta(alpha, beta: Real; profondeur: Byte; YJoue: Boolean): Real;
Public | Function ChercheAJouer(x, y: Byte): Boolean;
Public | Function ChercheAJouerAdversaire(x, y: Byte): Boolean;
Public | Procedure Chercher;
Public | Procedure ChercherAdversaire;
Public | Procedure ChercherSuites;
Public | Procedure ChercherSuitesAdversaire;
Public | Procedure DetruireBranchesDifferentes(j: Byte);
Public | Procedure dump;
Public | Function Evaluation(YJoue: Boolean): Real;
Public | Function Negascout(alpha, beta: Real; profondeur: Byte; YJoue: Boolean): Real;
Public | Procedure PassePourSuite;
Public | Function TrouverCase(Score: Integer): Byte;
Public | Procedure _dump(Var fic: Text; formatage: String);

Description

Public Constructor Create;

Public Destructor Destroy; Override;

Public Function AlphaBeta(alpha, beta: Real; profondeur: Byte; YJoue: Boolean): Real;

Public Function ChercheAJouer(x, y: Byte): Boolean;

Public Function ChercheAJouerAdversaire(x, y: Byte): Boolean;

Public Procedure Chercher;

Public Procedure ChercherAdversaire;

Public Procedure ChercherSuites;

Public Procedure ChercherSuitesAdversaire;

Public Procedure DetruireBranchesDifferentes(j: Byte);

Public Procedure dump;

Public Function Evaluation(YJoue: Boolean): Real;

Public Function Negascout(alpha, beta: Real; profondeur: Byte; YJoue: Boolean): Real;

Public Procedure PassePourSuite;

Public Function TrouverCase(Score: Integer): Byte;

Public Procedure _dump(Var fic: Text; formatage: String);


YABOG: moteur: Classe TYABOG

Classe TYABOG

Unité

moteur

Déclaration

type TYABOG = class

Description

Champs

 | Nom | Description
Public | Couleur |
Public | DernierCoupPasse |
Public | Fin |
Public | Profondeur |
Public | Situation |
Public | SuiteHistorique |
Public | TypeJeu |
Public | YabogJoue |

Méthodes

Aperçu

Public | Constructor Create(NomProfil: String);
Public | Destructor Destroy; Override;
Public | Function ChercheAJouer(CaseAJouer: Byte): Boolean;
Public | Function ChercherCaseAJouer(_Valeur: Real): Byte;
Public | Procedure FinDePartie;
Public | Procedure InitClassique(_Couleur: TCouleur);
Public | Function Jouer: Real;

Description

Public Constructor Create(NomProfil: String);

Public Destructor Destroy; Override;

Public Function ChercheAJouer(CaseAJouer: Byte): Boolean;

Public Function ChercherCaseAJouer(_Valeur: Real): Byte;

Public Procedure FinDePartie;

Public Procedure InitClassique(_Couleur: TCouleur);

Public Function Jouer: Real;


YABOG: Param

Unité Param

Description

Classes, interfaces and objects

Nom | Description
Classe TPagesDlg |

Variables

Nom | Description
PagesDlg |


YABOG: Param: Classe TPagesDlg

Classe TPagesDlg

Unité

Param

Déclaration

type TPagesDlg = class(TForm)

Description

Champs

 | Nom | Description
Public | CancelBtn |
Public | FIniFileName | Public declarations
Public | GroupBox1 |
Public | HelpBtn |
Public | Label1 |
Public | Label3 |
Public | Label4 |
Public | Label5 |
Public | Label6 |
Public | OKBtn |
Public | PageControl1 |
Public | Panel1 |
Public | Panel2 |
Public | PortLANEdit |
Public | Socks4RadioButton |
Public | Socks5RadioButton |
Public | SocksAuthCheckBox |
Public | SocksPasswordEdit |
Public | SocksPortEdit |
Public | SocksServerEdit |
Public | SocksUsercodeEdit |
Public | TabSheet1 |
Public | TabSheet2 |
Public | TabSheet3 |

Méthodes

Aperçu

Public | Procedure AfficheParam;
Public | Procedure FormClose(Sender: TObject; Var Action: TCloseAction);
Public | Procedure FormCreate(Sender: TObject);
Public | Procedure FormShow(Sender: TObject);
Public | Procedure SauveParam;

Description

Public Procedure AfficheParam;

Public Procedure FormClose(Sender: TObject; Var Action: TCloseAction);

Public Procedure FormCreate(Sender: TObject);

Public Procedure FormShow(Sender: TObject);

Public Procedure SauveParam;


YABOG: Skin

Unité Skin

Description

Gestion des skins de YABOG

Pas de véritable commentaires pour ce source. A FAIRE : - mettre le code au propre - rendre le code plus robuste - intégrer véritablement les curseurs - intégrer les sons - installation des polices - voir pour radiobuttons - finaliser boutons - gérer section "author" - possibilité d'utiliser des MP3 et des GIF/JPG

Classes, interfaces and objects

Nom | Description
Classe TDamier |
Classe TSkinButton |
Classe TSkinEdit |
Classe TSkinGlobal |
Classe TSkinLabel |
Classe TSkinMemo |
Classe TSkinPopupMenu |
Classe TSkinSon |

Types

Nom | Description
TTypeSon |

Variables

Nom | Description
SkinGlobal |

Auteur

Eric Sallou <esallou@free.fr>

Dernière modification

1er Janvier 2004


YABOG: Skin: Classe TDamier

Classe TDamier

Unité

Skin

Déclaration

type TDamier = class(TImage)

Description

Champs

 | Nom | Description
Public | AffichageDesPossibles |
Public | AffichageDuDernier |
Public | PionBlanc | Image du pion blanc
Public | PionJoueBlanc | Image du dernier pion joué (blanc)
Public | PionJoueNoir | Image du dernier pion joué (noir)
Public | PionNoir | Image du pion noir
Public | PionPossible | Image de la case possible
Public | PionVide | Image de la case vide

Méthodes

Aperçu

Public | Constructor Create(Owner: TComponent); Override;
Public | Destructor Destroy; Override;
Public | Procedure DisplayBoard;
Public | Procedure Initialise(repertoire: String);

Description

Public Constructor Create(Owner: TComponent); Override;

Public Destructor Destroy; Override;

Public Procedure DisplayBoard;

Public Procedure Initialise(repertoire: String);


YABOG: Skin: Classe TSkinButton

Classe TSkinButton

Unité

Skin

Déclaration

type TSkinButton = class(TImage)

Description

Champs

 | Nom | Description
Public | ButtonDown | Image du bouton descendu
Public | ButtonMove | Image du bouton normal?
Public | ButtonOut | Image du bouton normal
Public | ButtonUp | Image du bouton relevé
Public | TestAffiche |

Méthodes

Aperçu

Public | Constructor CreateIni(Skin, Langue, Nom: String; Owner: TComponent);
Public | Destructor Destroy; Override;
Public | Procedure MouseDown(Sender: TObject; Button: TMouseButton;Shift: TShiftState; X, Y: Integer);
Public | Procedure MouseMove(Sender: TObject; Shift: TShiftState; X,Y: Integer);
Public | Procedure MouseUp(Sender: TObject; Button: TMouseButton;Shift: TShiftState; X, Y: Integer);

Description

Public Constructor CreateIni(Skin, Langue, Nom: String; Owner: TComponent);

Public Destructor Destroy; Override;

Public Procedure MouseDown(Sender: TObject; Button: TMouseButton;Shift: TShiftState; X, Y: Integer);

Public Procedure MouseMove(Sender: TObject; Shift: TShiftState; X,Y: Integer);

Public Procedure MouseUp(Sender: TObject; Button: TMouseButton;Shift: TShiftState; X, Y: Integer);


YABOG: Skin: Classe TSkinEdit

Classe TSkinEdit

Unité

Skin

Déclaration

type TSkinEdit = class(TEdit)

Description

Méthodes

Aperçu

Public Constructor CreateIni(Repertoire, Langue, Nom: String; Owner: TComponent);

Description

Public Constructor CreateIni(Repertoire, Langue, Nom: String; Owner: TComponent);


YABOG: Skin: Classe TSkinGlobal

Classe TSkinGlobal

Unité

Skin

Déclaration

type TSkinGlobal = class

Description

Champs

 | Nom | Description
Public | Damier |
Public | NomCurseurs |
Public | NomFileCurseurs |
Public | NomLang |
Public | NomSkin |
Public | Repertoire |
Public | Son |

Méthodes

Aperçu

Public | Constructor CreateIni(_NomSkin, _NomLang, _Repertoire, _Profil: String; Owner: TComponent);
Public | Destructor Destroy; Override;

Description

Public Constructor CreateIni(_NomSkin, _NomLang, _Repertoire, _Profil: String; Owner: TComponent);

Public Destructor Destroy; Override;


YABOG: Skin: Classe TSkinLabel

Classe TSkinLabel

Unité

Skin

Déclaration

type TSkinLabel = class(TLabel)

Description

Méthodes

Aperçu

Public Constructor CreateIni(Repertoire, Langue, Nom: String; Owner: TComponent);

Description

Public Constructor CreateIni(Repertoire, Langue, Nom: String; Owner: TComponent);


YABOG: Skin: Classe TSkinMemo

Classe TSkinMemo

Unité

Skin

Déclaration

type TSkinMemo = class(TMemo)

Description

Méthodes

Aperçu

Public Constructor CreateIni(Repertoire, Langue, Nom: String; Owner: TComponent);

Description

Public Constructor CreateIni(Repertoire, Langue, Nom: String; Owner: TComponent);


YABOG: Skin: Classe TSkinPopupMenu

Classe TSkinPopupMenu

Unité

Skin

Déclaration

type TSkinPopupMenu = class(TPopupMenu)

Description

Champs

 | Nom | Description
Public | RepertoireAppli |

Méthodes

Aperçu

Public | Constructor CreateIni(Repertoire, Skin, Langue, Profil, Nom: String; Owner: TComponent);
Public | Destructor Destroy; Override;
Public | Procedure Checker(Sender: TObject);

Description

Public Constructor CreateIni(Repertoire, Skin, Langue, Profil, Nom: String; Owner: TComponent);

Public Destructor Destroy; Override;

Public Procedure Checker(Sender: TObject);


YABOG: Skin: Classe TSkinSon

Classe TSkinSon

Unité

Skin

Déclaration

type TSkinSon = class

Description

Méthodes

Aperçu

Public | Constructor create(Skin : String);
Public | Destructor destroy;
Public | Procedure play(TypeSon : TTypeSon);

Description

Public Constructor create(Skin : String);

Public Destructor destroy;

Public Procedure play(TypeSon : TTypeSon);


YABOG: Traduc

Unité Traduc

Description

Classes, interfaces and objects

Nom | Description
Classe TTraducteur |

Variables

Nom | Description
Traducteur |


YABOG: Traduc: Classe TTraducteur

Classe TTraducteur

Unité

Traduc

Déclaration

type TTraducteur = class

Description

Champs

 | Nom | Description
Public | LesMessages |

Méthodes

Aperçu

Public | Constructor CreateIni(NomFichier : String);
Public | Destructor Free;
Public | Function MessageTraduit(Num : Integer) : String;

Description

Public Constructor CreateIni(NomFichier : String);

Public Destructor Free;

Public Function MessageTraduit(Num : Integer) : String;


YABOG: Utils

Unité Utils

Description

Fonctions et procédures

Aperçu

Function AfficheNomCase(valeur: Byte): String;

Description

Function AfficheNomCase(valeur: Byte): String;


YABOG: _Bib

Unité _Bib

Description

Gestion de la bibliothèque d'ouvertures

Pas de véritable commentaires pour ce source. A FAIRE : - mettre le code au propre - rendre le code plus robuste

Classes, interfaces and objects

Nom | Description
Classe TBib |
Classe TValeurCoup |

Auteur

Eric Sallou <esallou@free.fr>

Dernière modification

1er Janvier 2004


YABOG: _Bib: Classe TBib

Classe TBib

Unité

_Bib

Déclaration

type TBib = class

Description

Champs

 | Nom | Description
Public | FicFinal |
Public | Noirs |
Public | Tous |

Méthodes

Aperçu

Public | Constructor Create;
Public | Constructor Creer(NomBib: String);
Public | Destructor Destroy; Override;
Public | Destructor Detruire;
Public | Procedure AjouterUnFichier(NomFichier: String);
Public | Procedure AjouterUnRepertoire(NomRepertoire: String);
Public | Procedure Charge(NomFichier: String);
Public | Function ChercherCoup(Histo: String): String;
Public | Procedure Maj(Historique: String; Score: Byte);
Public | Procedure Sauve(NomFichier: String);
Public | Function TraitementBlancs(Historique: String): Byte;
Public | Function TraitementBranche(Historique: String): Byte;
Public | Function TraitementNoirs(Historique: String): Byte;

Description

Public Constructor Create;

Public Constructor Creer(NomBib: String);

Public Destructor Destroy; Override;

Public Destructor Detruire;

Public Procedure AjouterUnFichier(NomFichier: String);

Public Procedure AjouterUnRepertoire(NomRepertoire: String);

Public Procedure Charge(NomFichier: String);

Public Function ChercherCoup(Histo: String): String;

Public Procedure Maj(Historique: String; Score: Byte);

Public Procedure Sauve(NomFichier: String);

Public Function TraitementBlancs(Historique: String): Byte;

Public Function TraitementBranche(Historique: String): Byte;

Public Function TraitementNoirs(Historique: String): Byte;


YABOG: _Bib: Classe TValeurCoup

Classe TValeurCoup

Unité

_Bib

Déclaration

type TValeurCoup = class

Description

Champs

 | Nom | Description
Public | Score |

Méthodes

Aperçu

Public Constructor Create(tempscore: Byte);

Description

Public Constructor Create(tempscore: Byte);


YABOG: _Biblio

Unité _Biblio

Description

Classes, interfaces and objects

Nom | Description
Classe TForm1 |

Variables

Nom | Description
Form1 | 0


YABOG: _Biblio: Classe TForm1

Classe TForm1

Unité

_Biblio

Déclaration

type TForm1 = class(TForm)

Description

Champs

 | Nom | Description
Public | Bib | Déclarations publiques
Public | Button1 |
Public | Button2 |
Public | Button3 |
Public | Button4 |
Public | Button5 |
Public | Button6 |
Public | Label1 |
Public | Label2 |
Public | OpenDialog1 |

Méthodes

Aperçu

Public | Procedure Button1click(Sender: TObject);
Public | Procedure Button2click(Sender: TObject);
Public | Procedure Button3click(Sender: TObject);
Public | Procedure Button4click(Sender: TObject);
Public | Procedure Button5click(Sender: TObject);
Public | Procedure Button6Click(Sender: TObject);
Public | Procedure Formclose(Sender: TObject;Var Action: TCloseAction);
Public | Procedure Formcreate(Sender: TObject);

Description

Public Procedure Button1click(Sender: TObject);

Public Procedure Button2click(Sender: TObject);

Public Procedure Button3click(Sender: TObject);

Public Procedure Button4click(Sender: TObject);

Public Procedure Button5click(Sender: TObject);

Public Procedure Button6Click(Sender: TObject);

Public Procedure Formclose(Sender: TObject;Var Action: TCloseAction);

Public Procedure Formcreate(Sender: TObject);


YABOG: _systeme

Unité _systeme

Description

Classes, interfaces and objects

Nom | Description
Classe TSysteme |


YABOG: _systeme: Classe TSysteme

Classe TSysteme

Unité

_systeme

Déclaration

type TSysteme = class

Description

Méthodes

Aperçu

Public | Function ApplicationVersion: String;
Public | Function CarteSon: Boolean;
Public | Procedure Memoire(Var pourcentageutilise, physique,paginee, virtuelle: String);

Description

Public Function ApplicationVersion: String;

Public Function CarteSon: Boolean;

Public Procedure Memoire(Var pourcentageutilise, physique,paginee, virtuelle: String);


YABOG: Class Hierarchy

Class Hierarchy

  • TEdit
    • TSkinEdit
  • TForm
    • TForm1
    • TFormPrincipal
    • TPagesDlg
  • TImage
    • TDamier
    • TSkinButton
  • TLabel
    • TSkinLabel
  • TMemo
    • TSkinMemo
  • TObject
    • TBib
    • TLAN
    • TSitu
    • TSkinGlobal
    • TSkinSon
    • TSysteme
    • TTraducteur
    • TValeurCoup
    • TYABOG
  • TPopupMenu
    • TSkinPopupMenu


YABOG: Toutes les classes, interfaces et objets

Toutes les classes, interfaces et objets

Nom | Unité | Description
TBib | _Bib |
TDamier | Skin |
TForm1 | _Biblio |
TFormPrincipal | IHM |
TLAN | LAN |
TPagesDlg | Param |
TSitu | moteur |
TSkinButton | Skin |
TSkinEdit | Skin |
TSkinGlobal | Skin |
TSkinLabel | Skin |
TSkinMemo | Skin |
TSkinPopupMenu | Skin |
TSkinSon | Skin |
TSysteme | _systeme |
TTraducteur | Traduc |
TValeurCoup | _Bib |
TYABOG | moteur |


YABOG: Tous les types

Tous les types

Nom | Unité | Description
TCouleur | moteur |
TLesJoueurs | IHM |
TLigne | moteur |
TTypeSon | Skin |


YABOG: Toutes les variables

Toutes les variables

Nom | Unité | Description
Form1 | _Biblio | 0
FormPrincipal | IHM |
PagesDlg | Param |
SkinGlobal | Skin |
Traducteur | Traduc |
YABOG | moteur |


YABOG: Toutes les constants

Toutes les constants

Nom | Unité | Description
CaseX | IHM | valeur des cases se référant à Label1 et autres
CaseX | moteur | Tester List.Capacity := Count avant chaque ADD


YABOG: Toutes les fonctions et procédures

Toutes les fonctions et procédures

Nom Unité Description


YABOG: Tous les identificateurs

Tous les identificateurs

Nom | Unité | Description
AfficheNomCase | Utils |
CaseX | IHM | valeur des cases se référant à Label1 et autres
CaseX | moteur | Tester List.Capacity := Count avant chaque ADD
Form1 | _Biblio | 0
FormPrincipal | IHM |
PagesDlg | Param |
SkinGlobal | Skin |
TBib | _Bib |
TCouleur | moteur |
TDamier | Skin |
TForm1 | _Biblio |
TFormPrincipal | IHM |
TLAN | LAN |
TLesJoueurs | IHM |
TLigne | moteur |
TPagesDlg | Param |
Traducteur | Traduc |
Triangle | moteur |
TSitu | moteur |
TSkinButton | Skin |
TSkinEdit | Skin |
TSkinGlobal | Skin |
TSkinLabel | Skin |
TSkinMemo | Skin |
TSkinPopupMenu | Skin |
TSkinSon | Skin |
TSysteme | _systeme |
TTraducteur | Traduc |
TTypeSon | Skin |
TValeurCoup | _Bib |
TYABOG | moteur |
YABOG | moteur |


YABOG: Legend

Legend

Private | Private
Protected | Protected
Public | Public
Published | Published